Author Topic: Any way to get the Mac to quit bugging me. . .  (Read 257 times)

Offline beacher

  • TS Addict
  • *****
  • Posts: 1493
    • View Profile
    • http://sonofabeach-beacher.blogspot.com/
Any way to get the Mac to quit bugging me. . .
« on: September 05, 2019, 06:06:10 PM »
about updating my OS?  I'm running a mig-'12 MB Pro running OS 10.14.5, and have NO intention of going any further, since I have a lot of applications that wont be usable under any further updates, and I'm getting sick of being bugged, every day, to update to the newest and greatest.  Yes, sometime in the foreseeable future, I'll be looking for a new machine, but it's going to be awhile.  In the meantime, if anyone has any advice to short circuit this loop I've gotten caught in, I'd truly appreciate it, and thanks in advance!

Offline Xairbusdriver

  • Administrator
  • TS Addict
  • *****
  • Posts: 25582
  • 27" iMac (mid-17), Mac mini, both 10.14.6
    • View Profile
    • Mid-South Weather
Re: Any way to get the Mac to quit bugging me. . .
« Reply #1 on: September 05, 2019, 08:56:30 PM »
Good question.

I did find one rather dated solution (11/17). Actually, there are three "temporary" and one "permanent" solutions. This will only apply to Apple software, of course. The permanent one requires accessing the System Prefs->App Store. However, you probably don't have that in System Prefs, I certainly don't with Mojave macOS 10.14. However, you do have one called "Software Update". In there, the key pref is "Check for updates". Make sure that is UN-checked. :Thinking:

The only other item in that Pref that I use is the "Install system data files and security updates". That's not what I did before Mojave. I've decided security updates are more important and even problem-causing security updates get fixed pretty quickly and are rather rare. :dntknw:

Hope that helps.

You might also try scheduling "Do Not Disturb" in the Notifications System Pref. Basically, if you have the Mac running on a schedule or you simply turn it ON/OFF regularly, you can set that time period in the Notification Pref. That will stop ALL notifications during that time period.

If you are still getting notifications about a specific 32-bit app, you may be able to select it in the list of apps on the left-hand area of Notifications prefs and Select "None" for style and UN-check all the checkboxes.

If none of these methods work, I suggestion a piece of opaque tape in the Notifications area os the screen. Duct® tape comes in many colors. Hopefully one will go well with your Desktop image. :thumbup: :doh: :WOW:
« Last Edit: September 05, 2019, 09:44:48 PM by Xairbusdriver »
I don’t like the fact that my chances of survival seem to be linked to the common sense of others. :Thinking:

Offline beacher

  • TS Addict
  • *****
  • Posts: 1493
    • View Profile
    • http://sonofabeach-beacher.blogspot.com/
Re: Any way to get the Mac to quit bugging me. . .
« Reply #2 on: September 06, 2019, 11:22:59 AM »
Thanks, Jim; I'll explore those options this afternoon!  As far as the duct tape. . .The piece of post-it note that I've had covering the camera (in my effort to prevent me from getting that extortionist email [BTW, I must not be in your address book, as I never received “your” video!  :rofl:]!) has, over the years, almost become invisible!   :toothgrin:

Offline Xairbusdriver

  • Administrator
  • TS Addict
  • *****
  • Posts: 25582
  • 27" iMac (mid-17), Mac mini, both 10.14.6
    • View Profile
    • Mid-South Weather
Re: Any way to get the Mac to quit bugging me. . .
« Reply #3 on: September 06, 2019, 11:38:43 AM »
Let us know how things work out. I may try using one of these on my wife's MBP. She is always fearful of any kind of notification or 'update' request. ;)
I don’t like the fact that my chances of survival seem to be linked to the common sense of others. :Thinking:

Offline beacher

  • TS Addict
  • *****
  • Posts: 1493
    • View Profile
    • http://sonofabeach-beacher.blogspot.com/
Re: Any way to get the Mac to quit bugging me. . .
« Reply #4 on: September 09, 2019, 11:15:57 AM »
 :yahoo:It worked, Jim! :clap: I turned off the notifications, and, POOF!  Problem solved!  :thanx: soooooooo much!

Offline Xairbusdriver

  • Administrator
  • TS Addict
  • *****
  • Posts: 25582
  • 27" iMac (mid-17), Mac mini, both 10.14.6
    • View Profile
    • Mid-South Weather
Re: Any way to get the Mac to quit bugging me. . .
« Reply #5 on: September 09, 2019, 04:53:29 PM »
But how will you know when Tim Cook announces you have been selected to receive a free 2025 iMac with all the apps you use running in 128 bit mode?! :Thinking: :dntknw: :WOW:
I don’t like the fact that my chances of survival seem to be linked to the common sense of others. :Thinking: