Welcome to Techsurvivors > Tech

an old tip but still a good one

(1/1)

jchuzi:
I tried to launch TechToolPro 12.0.3 and it froze (spinning beachball). I uninstalled it, reinstalled it, and got nowhere. Micromat sent me a fresh installer but that didn't solve the problem. At Micromat's request, I sent them a system report. Within a minute, a lightbulb flashed in my mind: Restart!

Problem solved! This has solved issues with other apps (notably Microsoft AutoUpdate) and I should have thought of it first. Duh!!!   :blush:

Just a thought and reminder to everyone...

Xairbusdriver:
So, you have a Microsoft app installed? :Thinking: Well... there's your problem! :blink: :whistling: :dntknw:

 :blush-anim-cl: Actually, I finally checked to "Automatically Update" thing for Wurd/Xsel/etc. I never use them but have to be prepared for SWMBO's help request since she does. Her versions come from the App Store, so I trust those have been checked for at least working installing/correctly. :wallbash:

Reminds me, is Disk Warrior ever going to get updated? :wallbash: Or has Apple fixed the OS file system so it will never, ever get corrupted directories? :coolio:

...we now return you to the previous topic

jchuzi:
Disk Warrior hasn't been updated for at least 2 years and, as I understand it, Apple's file system is so stable that DW is unnecessary (at least Apple will think so). As to Microsoft, the only Office app that I use is Word because, oddly enough, I find it to be fairly intuitive and trouble-free compared to Pages, Libre Office, and some others that I have tried. I downloaded and installed Bean and Growly Write (and they look interesting) but I haven't used them. At any rate, MS Word does what I want so I bite the bullet and pay the fee. Life is too short to quibble.

Navigation

[0] Message Index

Go to full version