Author Topic: "This Connection Is Not Private"  (Read 51 times)

Offline Sooz

  • Super Poster
  • ***
  • Posts: 440
    • View Profile
"This Connection Is Not Private"
« on: June 30, 2020, 01:42:23 PM »
When I'm on Safari v 11.1.1, and try to go to the Aldi website (www.aldi.us), I get the message that this connection is not private. My clock and my calendar are both fine, but wait!!! When I use Firefox  77.0.1 (Firefox says it's up to date) to go to Aldi, I actually get to the Aldi website.   :wacko:

Why do I get the popup that's a big warning about a website impersonating the aldi website and,more importantly, how do I get around it (only if it's a simple fix pls).  Screenshot below.   I know I can always use Firefox, but I do like Safari as well.

Thanks!!!
Smiles,
Sooz
Desktop iMac, running OS X El Capitan 10.11.6, 16 GB installed, with Time Machine and SuperDuper! backup on two external hard drives...and I like to bake.

Offline Xairbusdriver

  • Administrator
  • TS Addict
  • *****
  • Posts: 25582
  • 27" iMac (mid-17), Mac mini, both 10.14.6
    • View Profile
    • Mid-South Weather
Re: "This Connection Is Not Private"
« Reply #1 on: June 30, 2020, 02:38:31 PM »
There are multiple reasons for that to happen, so we need to try to determine why the two different apps result in different results.
  • Have you emptied Safari cache lately?
    a. Yes
    b. No
    c. Want to know how
  • How are you going to the Aldi site in Safari?
    a. A bookmark
    b. Some non-Aldi website
    c. Typing in the url
  • Will the latest version of Safari not run on your OS?
  • Have you tried any of the solutions offered in search engine 'hits'?
« Last Edit: June 30, 2020, 02:51:31 PM by Xairbusdriver »
I don’t like the fact that my chances of survival seem to be linked to the common sense of others. :Thinking:

Offline Sooz

  • Super Poster
  • ***
  • Posts: 440
    • View Profile
Re: "This Connection Is Not Private"
« Reply #2 on: June 30, 2020, 09:50:30 PM »
Jim, thanks for the reminder! It's been while. 
Yes, please, walk me through how to clear the cache for Safari!   :D

I typed in aldi.us and got the same "not secure" website info pop up box.

When I got to the Aldi site by way of Firefox that did not have the warning, I just copied the address that was in my search box on Firefox, and then pasted that into Safari. But wait! When I did that, I got the same warning message on Safari.

Yuppers, I typed in the URL (aldi.us) and got the pop up warning on Safari.

Then I tried to get to Aldi by way of their confirmation email (for when I signed up for shopping on their website via Instacart), & I got the same warning. Then, I clicked on some of the search results from duckduckgo and there was no joy in Mudville.

I'm pretty sure this is user error! 

I'm going to log off for now, I'm "of an age" where I now have to renew my Driver's License by taking a written test this week, and hopefully that will be good for another 5 years for renewal by mail.  I'd best study, though!

Smiles,
Sooz
Desktop iMac, running OS X El Capitan 10.11.6, 16 GB installed, with Time Machine and SuperDuper! backup on two external hard drives...and I like to bake.

Offline Xairbusdriver

  • Administrator
  • TS Addict
  • *****
  • Posts: 25582
  • 27" iMac (mid-17), Mac mini, both 10.14.6
    • View Profile
    • Mid-South Weather
Re: "This Connection Is Not Private"
« Reply #3 on: June 30, 2020, 10:18:24 PM »
I think the correct url for Aldi, in the US, is Aldi.us. Aldi.com should take you to the corporation website from which you can go to the site fro the various countires where they have stores.
  • Australia
  • Austria
  • Belgium
  • Nederlands (lang: Français / Deutsch)
  • China
  • Denmark
  • France
  • Germany:  (divisions?: ALDI Nord | ALDI SÜD)
  • Great Britain
  • Hungary
  • Ireland
  • Switzerland
  • Italy
  • Luxembourg  (lang: Deutsch / Français)
  • Netherlands
  • Poland
  • Portugal
  • Slovenia
  • Spain
  • Switzerland (lang: Deutsch / Français / Italiano
  • USA
BTW, I don't get any kind of warning at either site. I suspect that your old version of Safari is not as up-to-date about EU security rules. And FF 77 is as up-to-date as you can get from those developers.

The easiest way to clear caches even Safari 11 is to enable the "Develop" Menu.
  • Open Safari prefs.
  • Click the Advanced tab.
  • Look for a checkbox at the bottom of the window labeled "Show develop in the menu bar".
  • Click that checkbox.
Now, look at the many menu items in that new menu. The only one you really need is about half way down the list. It's the 14th item in my menu. It's called... (drum roll, please)"Empty Caches". :WOW: However, it may not solve the warning problem you are having if it's due to the browser age. :wallbash:
I don’t like the fact that my chances of survival seem to be linked to the common sense of others. :Thinking: